Coding with SPIP 3.0
SPIP3.0 Technical Documentation

> > > Requirements and basic description

Requirements and basic description

SPIP 2.1 requires PHP version 5.0 or higher and at least 10MB of memory.
It also requires a database (MySQL, Postgres or SQLite are supported).

The public website (front-office) is visible to all visitors by default, but it can be restricted to certain users, by section, if required. The private interface (back-office) is accessible only to persons authorised to manage the software or site content.