Home > Bug reports > Mettre l’article à jour pour spip 3. et +

Bug report #348 - Mettre l’article à jour pour spip 3. et +

Created on Monday 6 May 2019 by Franck

Assigned to:

Autre version de ce texte : sur contrib

Hello, il faudrait mettre à jour:
https://programmer.spip.net/Gestion-des-dependances

<necessite nom="prefixe" version="[version_min;version_max]" />
  1. nom est le nom du préfixe du plugin, ou "SPIP" pour une dépendance directe à SPIP,
  2. version optionnellement peut indiquer la version minimum et/ou la version maximum d’un plugin.
    - Les crochets indiquent que la version limite est comprise dedans,
    - les parenthèses indiquent que la version limite n’est pas comprise.
    - Depuis spip 3.0.0 il est recommandé de mettre une * en fin de borne de compatibilité pour indiqué que cela concerne toute les version de z concernant la version
// necessite saisies 2.0.0 minimum
<necessite nom="saisies" compatibilite="[2.0.0;)" />
// necessite saisies < 2.0.0
<necessite nom="saisies" compatibilite="[;2.0.0)" />
// necessite saisies >= 2.0.0, et <= 2.1.0
<necessite nom="saisies" compatibilite="[2.0.0;2.1.0]" />
// necessite saisies >= 3.0.0,
<necessite nom="saisies" compatibilite="[3.0.0;]" />
 
// spip_bonux 1.2.0 minimum
<necessite nom="spip_bonux" compatibilite="[1.2.0;]" />
// plugin de configuration
<utilise nom="cfg" version="[1.10.5;]" />

Depuis spip 3.1.0, il est possible de faire une dépendance à une version particulière de PHP
Exemple:

<necessite nom="php" compatibilite="[5.3.0;]" />

Depuis spip 3.2.0 il est possible de faire une dépendance concernant une lib de php.
Exemple:

<necessite nom="php:curl" compatibilite="[1.0.0;]" />

No comment

Bug report or comment only available for registered users.

Log in.